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Creative Commons License

Attribution-NonCommercial-ShareAlike 1.0

Attribution

You must give the original author credit.

@ Noncommercial

You may not use this work for commercial purposes, without the explicit permission
of the author.

Share Alike

If you alter, transform, or build upon this work, you may distribute the resulting
work only under a license identical to this one.

[SOITIE RISHTS RESERLIED

http://creativecommons.org/licenses/by-nc-sa/1.0/

Full legal license: http://creativecommons.org/licenses/by-nc-sa/1.0/legalcode

If you would like to use this for commercial purposes, please write to Colin Charles, at
byte@aeon.com.my or at PO BOX 8188, Monash University LPO, Clayton, Victoria, 3168, Australia.
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* You are free:

* to copy, distribute, display, and perform the work
* to make derivative works

And...
* For any reuse or distribution, you must make clear to others the
license terms of this work.

Any of these conditions can be waived if you get permission
from the author.



Quick Start

* File -> New -> Spreadsheet
* Tools -> Options

- configure Spreadsheet & Chart

* measurement units, what the Enter key does
(move/switch to Edit mode), calculation
accuracy, sort lists, change control, grid setup

* Tools -> Configure
- what's on the status/function bar

EREEEEEEE Copyright © 2003-2004, Colin Charles. Released under a Creative Commons License. Page 3
http://creativecommons.org/licenses/by-nc-sa/1.0/

Keyboard Shortcuts

Backspace - deletes contents of cell

F9 - recalculates the spreadsheet (Tools -> Cell Contents ->
AutoCalculate)

Home - move to first cell in row

End - move to last cell in row, corresponding to the last column
Shift+F4 - absolute & relative cell references

Shift+F5/F6 - trace dependents/precendents
Ctrl+PgUp/PgDown — move to previous/next sheet

File-format Compatibility

Microsoft Excel files, Lotus 1-2-3, CSV based files, HTML based
files as well as dBase files can be opened.

Saving to all the formats listed above is allowed, except for
Lotus 1-2-3.

When importing CSV/Tab-separated files, its a little different in
comparison to Excel (in terms of the delimiters used).



Entering Text & Nulmbers

\ [
This text runs across too wide
This text

* If text is wider, re-align it | * oo e
After applying line break

Before applying line break |

- Right-click cell -> Format Cells

- Alignment -> Line Break Selection Lists
- Hyphenation as an option ,
eDisplays
° F||||n Use mouse to all text Si‘:‘z“"m
g drag downwards entered ;tt
- exactly the same data withina ok
column
- incremented data Right-click |Lists
here Selection
Work
httpyCrontivecommons.org/oenses/bynosn i 0f o eense: Faged

As long as pre-requisite knowledge exists about spreadsheet
usage, inserting into spreadsheets is not a new idea.

Bitst veratx| [10 | B i U A
escream Vera SHI 0 [N ICRENERE Just type your numbers/text

Al Tl @ X v |13 into an appropriate row/column
i - A 13|‘/B/ | C
B 2

Filling in exactly the same data, you just need to Control+click
the cell, and drag in the direction you want to fill it in.

If filling by incrementing data is the aim, click the bottom right-
hand corner of the cell, and drag it down till you want the
incremented data to stop.

Selection Lists display all text entered within a column, for re-
use. Right-click a cell, and choose Selection List. Now, you can
input text that's already been inputted earlier (great for
repetitive text).



Columns & Rows

Click to select

. 4 entire column L4 ReSiZing
ﬁ rows/columns are
done via clicking

Click toselect

[ —— & dragging

Entire Row 4
* Insertion/Deletion
Clig toscloc. ) B of rows/colu_mns
E— happen by right-
; clicking the cell
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Relative & Absolute Cell References

* A1l -relative reference, which is good for automatic fill across
rows.

* $A$1 - absolute reference to the column and row, good for
referencing cells that will never change location.

* $A1 - absolute reference to the column and relative reference
to the row.



AutoFormat

e Select the area, Format -> AutoFormat

Format B
Select an Currency = [ o |
Currency 3D Cancel
AutoForlmat Currency Gray
that you d Currency Lavender el
like to use \ Currency Turquoise —elp
Gray
Green Add...
Lavender
Red Delete
ITurquoise
Yellow ~ More << |
Formatting Rename
M Number format ¥ Font ¥ Alignment
[+ Borders ¥ Battern [ AutoFit width and height
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AutoFormat only works when you have more than three rows
and three columns. Anything less than that, and AutoFormat is
disabled in the menu.

Clicking More, shows the Formatting overrides that will be
applied to the spreadsheet. If you feel that keeping the Font
similar, un-tick the Font option, so that your fonts stay the same
and will not get over-written by the AutoFormat.

Exercise: Create your own AutoFormat

Start by formatting a spreadsheet the way you want it to look. A
tip is that no data needs to be included, just row, column and
cell formatting (well, having data helps visualize it).

Select the formatted area, choose Format -> AutoFormat. Click
on Add, give it a name, and click OK. You will now have a new
AutoFormat to use.



Cell Formatting

Quick number formatting to
cells can be applied by clicking
on the Currency or Percent

b Set the Font COIOré icons on the Object bar.
Currency
* Set the 0 7= N
A% b ol
Background Color - I
* Set Borders around Percentage 7 f
cell to add/romove.

‘ = decimal places

R

Top aligned

|— | | Click the Borders icon to open the Borders
floating toolbar, where you can modify the
border of a sheet area.

[= =TI THE Lists
At
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Center aligned
Bottom aligned
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* Select cells, right click them, and use the Format Cells option.
Here you can control the cell attributes, like fonts, font effects,

alignment, borders, and so on.
* An option to enable cell protection exists as well.



Page Setup & Breaks

* Format -> Page
- Page options (like A4 size), etc...

* View -> Page Break Preview

* Non-scrolling horizontal/vertical regions
- Select area, Window -> Freeze

* Splitting views
- Select area, Window -> Split

EREEEEEEE Copyright © 2003-2004, Colin Charles. Released under a Creative Commons License. Page 8
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Splitting views can be handy in a large spreadsheet, or on a
monitor with a very low resolution.

Re-sizing the split window is performed by moving the cursor
over the split line until it changes shape.



Styles

* Exists in Calc too e e E——
® O O X Theme Selection
- Cell Styles - all — -
elements, cell o T LR
formatting included Diackberr Bush
B_Iu_e]earjs
- Page Styles - sacier
margins, borders, e
Millennium
headers/footers vaure -
Might
* Themes can be R ER———
easily applied El concel | ok |
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The button for themes (|) can be found at the main toolbar.



Calculating & Manipulating
Data

* Dmaths - http://www.dmaths.com/
- Writing formulas & vectors simplified

* Remember, left-to right calculations,
with algebraic ordering rules

- =5+15%2-12/3+4 gives 15 or 357

* Functions are powerful .
~ =A1+A2+A3+A4 -> =SUM(AI:A4)
- Click the Sum icon too z=

m

—
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Some basic operators:

*= - all formula must begin with this (=2+4)

*~ - exponent for power raising (=1072)

** - multiply

*/ - divide

*+ - add

*- - subtract

*: - range of included cells (=sum(A1:A5), means cells A1, A2, A3, A4,
and A5)

*; - non-consecutive range of cells (=sum(A1;A4;A7), means sum of cell
Al+A4+A7)

Remembering BODMAS (control via parentheses) is handy.

Some Boolean operators:

*< - less than

*> - greater than (=if(A5>B5;"This is going well”;"Happy | am!”)
*<= - less than or equal to

*>= - greater than or equal to

*<> - not equal to

*Control + click to include non-adjacent cells while you're making use of
the Sum icon.



AutoPilot

Function AutoPilot i

Al my = r
* Wizard to help build formulas
Functions Structure | AVERAGE Function resuie o5 Enter values
e Returns the average of a sample here or use
(& AVERAGE :
* B3 number 1(required) Fhe shrink
® A5 icon
Number 1, number 2;_are 1 to 30 numeric arguments representing a
population sample
numberl A|[B5 = :‘
number 2 ﬂ [AS ﬂ
number 3 ﬂ ﬂ
number 4 ﬂ E ﬂ

Formula Result |55

=AVERAGE(B5;A5)
The actual
formula
being built

I~ Array Help ‘ Cancel ‘ ‘ ‘ oK ‘
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Great for prototyping functions, as the results are shown in the
Function result field.

The Functions tab lists all available functions, while the
Structure tab shows the structure of the formula in question.
The shrink icon is allows you to select cells via the mouse,
rather than typing them in manually.



Sorting Data

* Select cells you want sorted |-

Sander

* Data -> Sort
* Set sort options, Sort! Apply the sorting

by Amount, and
use Ascending

* Can sort by one option, then Siunesints
by another (depending on ™
how complicated the sort is)

Whom Amount
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* The Options tab has plenty of settings. Default sorts are case
insensitive - turning this on if need be is an option.
* Changing the direction of sorting is also a useful option.



Filtering Data

* AutoFilter - displays
only the data you
want to see

* Select cells, click the
AutoFilter icon, then
click the drop down
heading

* Select an option, and
the data is filtered
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N
Sz 1o
% AutoFilter

Y Jan
- Standad - —
~Top10-

Colin

Dan

[+]

Louis

Sander \

Whom  [#lAmount  ‘why
Colin 19 FOSSAP
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If the AutoFilter icon doesn't exist, Data -> Filter -> AutoFilter
will perform exactly the same action.

In the above example, the entire Whom column was selected,
the AutoFilter was applied, upon choosing, the entry “Colin”
was chosen, and the subsequently displayed data was “Colin 19
FOSSAP”. All the other data gets “hidden”, when the AutoFilter

is in use.



Conditional Formatting

* Format -> Conditional Formatting

* Remember to set Styles for the
formatting to work

Whorn Conditional Formatting has
Dan been applied with the

Colin Blrossap Heading 1 style, and the
text has changed.

Sander

Louis

The
condition
W Condffiom--
|Ce|| value is j |greater an j ‘20 E3
Cell Style |Heading1 A
What to do?
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Combining cells

* Simple concatenation: rposr
- ="Age: “&B1
* More “advanced” usage includes:

- =CONCATENATE("He is ";B1;" now, and will
be ";SUM(B1+1);" next year.")

54
He is 54 now, and will be 55 Mt year. A call to SUM() was performed.

* When would you merge cells?
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Concatenation is one of the functions that Calc offers.

Exercise: Merging cells

Input some data, that you concatenated before — using the
example above is fine.

Select the cells, Format -> Merge Cells -> Define. Notice now
that the value becomes text?

Un-merging via Format -> Merge Cells -> Remove will not bring
the formula back for you!

This is a warning to show that merging cells where there are
active formulas is probably a bad idea.



Efe x Charts

O” res arl in
* Select cells, click ¢ Double-click chart
Insert Chart to go into Edit i
. . . io
- Give it a position; mode
folltow on-screen e Right-click on w
v o OTTUICHIONS chart ]
S R P L @
o E ") - Chart wall & area
Whom — [#]Amount  why =1
o me, J - AutoFormat Chart
et QO T Wizard =
Louis LA o
Rom 1 Row 2 Row 3 Row 4 R 5 T8
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* When inserting a chart, the process is rather simple. First give
it a position, by clicking anywhere in the spreadsheet (it can be
in another Sheet as well). The AutoFormat chart pop-up
appears, showing the selected range. You might want to make
sure the First column as label and the First row as label options
are ticked (so you get a “nice” legend”). Select the type of chart
(scatter, pie, bar, etc...), select where grid lines should be, give
it a title, and voila! you have just created a chart.

* The toolbar for Edit mode is displayed in the left hand side.

* The AutoFormat Chart Wizard is very useful — you can make
extensive changes to the chart here, including changing the
type of chart, backgrounds, and others.



Protecting cells

* Tools -> Protect Document ->
Sheet/Document

- Enter a password (and remember it)

* Right-click on the cell(s), Format Cells,
and in the Cell Protection tab, tick
“Protect”
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Scenarios

Sheetl_Scenario_L

* Select cells Shectl scenanoy
* Tools -> Scenarios
- Give it a name
- Click OK
- Value can now be changed within the sheet
- Repeat to add more scenarios

* Scenarios are viewable in the Navigator
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GoaISeekS

etup
the formula
ATENATE | fio 3 «f [=(D2-CerBe .
A [e] ¢ o] e] F .Flnds
1_[Company Lots Purchase Sell value A~
T2 |opencffice.arg [ 100Q] 154l l=(D2-Cc2)*B2 Unkn OWn
variables
Default settings [ ] TOOIS -=>

Formula cell |$E$2

Goal Seek

Goal Seek successful.
Insert result (56.54) into current cell?
When it runs, it

Variable cell |sDs2 T x
/ = = finds an appropriate

/ﬁgure if successful
Company Lots |Purchase sell alue

Target value |5500

Enter expected
target value )
OpenOffice.org | 100 1.54 56.54 5500
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* Used when trying to achieve a goal. In the example provided,
with an expected value from the lots you own, to make a profit,
the formula is setup in F2. Since the aim is to make a profit, you
need to know the value to dump the lots at — so this is the
variable cell. The target value is what you hope to achieve

(profit).



Other stuff...

HPa . . . Red dot
* Revision control is like Writer denotes
* Inserting Notes . /
WwoDC .
- Click CeII, Insert -> Note FOSSAP
oswcC
- Type away

- Help -> Tips must be enabled
- Else note is not visible

FOSSAP
Why Consultations |
On mouse over, Wwbc
the noteis — ~ FOSSAP

displayed oswWC
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Remember, to put all data in a separate cell.

The logical break up of information in spreadsheets is essential.
If calculated values are incorrect, check all entered values
correctly; if it involves formulas, make sure you check the
parentheses usage.

Use Value Highlighting to see different sets of elements within
a spreadsheet - View -> Value Highlighting

{Cnmpany Lots Purchase Sell walue
OpenOffice.org 100 1.54| 56,54 5500




Printing

* Many options to control

* Repeating rows across pages
- select row to repeat
- Insert -> Names -> Define
e give it a name, and select “Repeat row”
- Format -> Print Ranges -> Edit

* under the “Rows to repeat” section, choose
the name provided earlier
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Things you can change include:

Page style window - Format -> Page Style

Print Options window

Cell Attributes window (like keeping protected cells from being
printed)

Print Ranges - Format -> Print Ranges

Page breaks



Thank You!

Colin Charles
byte@aeon.com.my
http://www.bytebot.net/
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