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Creative Commons License

Attribution-NonCommercial-ShareAlike 1.0

Attribution

You must give the original author credit.

@ Noncommercial

You may not use this work for commercial purposes, without the explicit permission
of the author.

Share Alike

If you alter, transform, or build upon this work, you may distribute the resulting
work only under a license identical to this one.

[SOITIE RISHTS RESERLIED

http://creativecommons.org/licenses/by-nc-sa/1.0/

Full legal license: http://creativecommons.org/licenses/by-nc-sa/1.0/legalcode

If you would like to use this for commercial purposes, please write to Colin Charles, at
byte@aeon.com.my or at PO BOX 8188, Monash University LPO, Clayton, Victoria, 3168, Australia.
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* You are free:

* to copy, distribute, display, and perform the work
* to make derivative works

And...

For any reuse or distribution, you must make clear to others the
license terms of this work.

* Any of these conditions can be waived if you get permission from the
author.



Quick Start

* File -> New -> Text Document

* Tools -> Options

- configure Text Document & HTML
Document options

* measurement units, formatting aids, fonts,
print options, tables, and more

* Tools -> Configure
- what's viewable on function/status bars

EREEEEEEn Copyright © 2003-2004, Colin Charles. Released under a Creative Commons License. Page 3
http://creativecommons.org/licenses/by-nc-sa/1.0/

* Writer can be started from most menu-based systems (GNOME/KDE
have icons for it).

* A regular word processor starts up, and it is similar to most other
existing packages out there.

Exercise
* Change the default measurement unit from inches to centimeters.

File-format Compatibility

* Proper interoperability achieved with Rich Text Format (.RTF)

* WordPerfect & Lotus WordPro files are incompatible

* KWriter files can be opened, if they were saved in their new OASIS
XML format

* Microsoft Word XP files will import with quite a high success rate

* AppleWorks will work with the XML that Writer can save as



Creating & Inserting
AutoText

* Allows composition of whole texts via
pre-defined shortcuts

* Works via typing a shortcut, then
hitting the F3 key (eg. “yt”"+F3)

* Edit and add new AutoText entries by:
- Edit -> AutoText
- Control + F3
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Test the AutoText: type “dt” and then hit the F3 key (dt F3) and see it
display some text.

Typing “yt” then hitting the F3 key gives the “Yours truly” line, with an
appropriate name if OpenOffice.org has been set up correctly.

Exercise: Create some AutoText

Type something into Writer, then select it

Edit -> AutoText

Give it (the newly highlighted AutoText) an appropriate name; at this
stage you can use the default shortcut given, or give it your own
shortcut.

Click the AutoText tab and select “New”

Now the AutoText is created properly and in the document, you can
use it by typing <shortcut nhame>+F3.

Now, for some fun: Using the AutoText feature that you've just learnt
about, type StarWriterTeam and see the output! That's an Easter Egg
)



Counts

* Word Counts: File -> Properties

- Refer to the Statistics tab. Keeps
information on page, character, line counts
and more

* Tools -> Line Numbering

- Adds visible line numbers to each and
every line or at line intervals
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Word counts are limited in the sense that they can't actually be
counts made for selections of text — something many writers find
very useful. To solve this, a macro has been written (as referenced
from the OpenOffice.org Unofficial FAQ:
file:///home/byte/WW W /openoffice/faq.html#Writerl). Visit
http://www.darwinwars.com/lunatic/bugs/oo_macros.html#bwc to
enable such a feature.

Exercise: Line Numbering

Get a fairly lengthy document (go surf the Internet, copy and paste
some text into your document). Fuffill the requirement where you use
uppercase Roman numerals, positioned at the right of the text at
every 3 lines.

Realize that counting blank lines (or not) is also an option



Within search text,
Search & Replace aniekx,,.

of the item you're

looking for
* Edit -> Find & Replace (Ctrl+F)
[E] Find & Replace
Search for ‘ j
| |
Ba.SlC\ Replace with j Atigutes... | Glose ‘
search Format... ‘L Help ‘
& replace Character
Options ?ormatting
[~ Whole words only I~ Match case I~ [Similarity search J
[~ Backwards r
[~ Regular expressions [~ Search for Styles

When searching for styles,
notice the Search/Replace field
changes accordingly
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The Find & Replace feature in OpenOffice.org is rather advanced,
allowing searching in styles, changing font attributes, as well as
supporting regular expressions.

Using the “Whole words only” option, searching will make sure the
whole word itself matches.

For an understanding of regular expressions, there are a few
examples like ? or $ that are used. Doing “man 7 regex” will give a lot
of examples that you can use (works on Linux or Mac OS X systems;
Windows systems can make use of Google help).

A Similarity Search can add, change or remove sets of characters. It
can even combine them.

Styles can be searched for and replaced with another style - for
example, searching for Text Body, you can replace it with Text Body
Indent. This saves precious time!



Character Formatting

Change lots of other

* Format -> Character ;characterproperties
B x

Font |Font Effects| Position | Hyperlink | Background |

Font Typeface Size
[Bitsiream Vera Sans| [Regul B
|JAvant Garde Gothic
Bitstream Charter Italic 13
14 |
15
16
18
20 I Preferred language
Language used

Font position
relative to the
line (shows — ™
the current
font in use)

Bitstream Vera Sans

The same font will be useel on both your printer and your sereen.

oK Cancel Help Reset
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Font Effects - allows changing from/to capitals, and so on. Can
emboss text, outline or even make text blink.

Position — Superscripting or subscripting text happens here. It
controls relatively where on the line the character sits. Characters can
be scaled or even rotated.

Hyperlink — documents that are linked to other documents.
Background colors of each character can be changed.



Paragraph Formatting

Will update and display a
° F Ol’mat -> preview automatically
Paragraph
- Indents & Spacing (of
lines)

- Text Alignment

—
I
- Text Flow — —
- Numbering
- Tabs

- Borders &
Background
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* Indents & Spacing - spacing above/below paragraph can be
controlled here. Some users of word-processors tend to be used to
spacings, except when at break. This is turned on by default — and is
enabled in Tools -> Options -> Text Document -> General.

* Text Flow controls breaks, as well as options to split paragraphs.
Hyphenation of text can be done automatically.



Page Formatting

* Format -> Page (changes Page Styles)

- Page - change the paper format (default is
Letter); specify page orientation properties
- Dividing the page into columns
e Similar to Format -> Columns

- Backgrounds, page borders and footnote
styles are set here

- Creation of headers & footers
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* Note that Format -> Page changes the settings for the default page
format.



Headers (and Footers)

Toggle to
turn on/off  6.gaizer | Page| Background Header |Footer| Borders | Columns | Faotnote |
Header

¥ Header on
¥ Same content left/right

Left margin 0.00cm 3:
Right margin 0.00cm 3: \\gh:;)l;g}euslg gin
Spacing 0.50cm 3:
Height 0.50cm 3:

W AutoFit height

More...

Borders / Note: Header

& background settings are the
same as settings
0K Cancel Help Reset | for the Footer
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Headers are turned on by default - accessing them usually comes
from Insert -> Header.

Clicking the More button allows you to change the background color
or even include a graphic.

Using Dynamic spacing allows it to override the spacing settings (so
the header expands to size).



Welcome to the Stylist!

Styles

Complimentary close

* Hit F11 to get the Stylist
 Each style controls

every aspect of its flow  |[r=im:

* Provides instant
formatting, automation, |f=am
consistency, and
provides for table of
contents generation y

Butomatic =]
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In Word, this is known as Page Styles — however, OpenOffice.org
really does provide more control over it, making it more FrameMaker
like.

Format -> Styles -> Catalog — shows the styles catalog and allows
changes to be made here too.

Conditional paragraph formatting can be created through drag &
drop - that means you can configure a certain look and feel, highlight
the selected text, and drop it into the Stylist window.

Control for many types of styles — Character, numbering & bullet
styles, including page and frame styles.



Templates

* Used for documents with a repetitive
nature to them (which includes
formatting, graphics, etc...)

* File -> Templates -> Save - saves the
current document as a template

* Default templates can be set, and
organized (File ->Templates ->
Organize)
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* 0O0Oo0 doesn't come with templates in a default install, but more
templates are available online for download and use. Currently, the
only known templates are two for Impress presentations.

Exercise: Create a template

* Don't you always create similar documents on a regular basis? Maybe
its a standard letter with the company letterhead? Maybe its a
standard letter for your child's school with regards to leave of
absence. We always have repetitive document creation.

* The task at hand is to create a memo or a fax template that you use
often, and the only thing that changes would be t he name and the
address field from letter to letter. Use all your knowledge about
template creation, and organization.

* This is important, as it will be used for a subsequent exercise.



Hyperlinking

* Insert -> Hyperlink

=

Path to the document to link

el
Works for
documents Decument
—

onthe WWW| T jierer Pt o o =

% Target in document

Mail & News Target ‘ g
URL
¥ | Document
Link to a Further settings .

- = nter link
local file == Frame M| b Text d 8| /Eame here
on disk New Document /

Text ‘
Name ‘
Apply Close Help ‘ Back ‘
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When a hyperlink is clicked, the document that it is linked to (or the
URL of a site), will actually load up in a new window. What this means
is that if you click a Calc file, it will open Calc up. Think about how
useful this is during presentations - right in the middle of a
presentation, loading up a spreadsheet is fine!
Websites tend to open up in a new Web window (which is basically

Writer).



DraWing in Writer Draw Functions
/

¢ Click the Draw Functions icon

Show Draw Functions

* A pop-up appears:
R/ BN TTVOCEOTTE DO

* Moving the mouse above any of the
above will present its tool tip

e Copyright © 2003-2004, Colin Charles. Released under a Creative Commons License. Page 14
http://creativecommons.org/licenses/by-nc-sa/1.0/

* Drawing a Line, Rectangle, Ellipse, Polygon, Curve, Freeform Line, Arc,
Ellipse Pie, and Circle Segments exist. Inserting Text, animating text,
as well as having callout's (comic-styled) can be performed here.

Exercise: Text Control

* Not quite “drawing”, but notice that advertisements placed at
community centers tend to have those vertically aligned tear out
phone numbers?

* By visiting Format -> Character -> Position -> Rotation/Scaling this
can be achieved.



Inserting Graphics

* Insert -> Graphics

- From File
* Imports all the “usual” graphics formats
* Enable previews by ticking Preview option

- Scan

e Can be a front-end to scanners

* Request an image from the scanner, and as
long as the scanner is detected, it will scan
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Scanning in Microsoft Windows platforms will work as long as the
TWAIN drivers are installed. Under GNU/Linux, the SANE drivers need
to be working - installing a scanner is definitely out of the scope of
this course however.



Cropping & Resizing

* Double-click the picture

B e —

New Document
Text

Actual cropped

i A () image

ey
Boundaries Type| Options | Wrap| Hyperlink | Graphics Crop |Burders‘ Background | Macro|
for cropping T Selected area
# Keep scale to crop
 Keep image size \ e /
A Leit 0.00° H 1 3.19" B %——’ .
Right 4.77" = Bottom 0.00" = i
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Scaling the image can also be performed at this screen.

Changing the image size (displayed) is also done here.

While the cropping is rather “primitive”, such a feature does exist -
for more control, usage of a graphical manipulation tool like The GIMP
(http://www.gimp.org/) would be more helpful.



Tables

* Quick Tables: Using the Insert Main
Toolbar

Insert - at the —

Main Toolbar =

Table can be
inserted rather
«———— quickly just

by selecting its
2x3 ‘ ‘ boundaries.

* [nsert -> Table (Control+F12)
- Provides more control initially
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Table Insertion for Beginners.

Name [Tale2  Give the table a name OK
Stz Cancel

Columns 5 3 How many columns and
Rows o z] rows are required? Help
Options

M Header First row is set to be the “header” row

I Repeat header If table goes across pages, repeat the row
I~ Don't split table
Borders are visible lines separating rows and
columns, and they show the overall table as it is
AutoFormat...

W Border

* AutoFormat is the option used to give your table a pre-formatted
form. Adding colors, changing the style the headers would behave in,
and many other options are available.

* To Format a table, right-click in a cell, then click Table. Or while in the
table Format -> Table.

* Many options, including that for text flow, column properties, borders
and text alignment within a table are set here.



Spreadsheets

* Insert -> Object -> OLE Object
* Create a new; use existing

* Allows conversion of a spreadsheet to a
Writer table

Insert OLE Object

" Createfrom file

Object typ

Cancel
OpenOffice.org 680 Spreadsheet
OpenOffice.org 680 Chart

Help
OpenOffice.org 680 Drawing
OpenOffice.org 680 Presentation

OpenOffice.org 680 Formula
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Getting Math Sorted

e Can insert «
& build
formulas m

Insert Objeci sn s tan oot W%
HFEoasz s
rd

sin' st tan! cf! W
Formula
Editor

~ [#]

N |\n5ert OpenOffice.org Math object|

sinh cosh  tonh  coth x|

sinh' cosh! tanh! coth!  w?

d Using | 5
MathML Fover me o
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The Selection dialog allows the insertion of various mathematical
symbols.
In the Formula Editor, typing in the Math Markup Language (MathML)

is fully allowed. To read up more about MathML, visit the W3C Math
Home at http://www.w3.0org/Math/.



* Good for books and longer documents

The Navigator

* Hit F5 or Edit -> Navigator

=} = 2E|
RE=Inciy

[=] Headings =l

[ Tables

[i] Text frame

W Graphics
B g OLE Ob]V

Object =

|Untitled1 (active) ]

Notice the
highlighted object?
The equation within
the document is one
of the OLE Objects
picked up by the
Navigator.
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Master Documents

* Basically any Writer file
- Made up of several files collated together
* File -> New -> Master Document

L
I [g 3o &
T

Insert new items
into t he document

Change position within
the Master Document

&
bk E G EE

EEEIication Form - Personal Detal
D More than one

document listed
here now
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Bookmarks

ookmarks : ® For Ia r er
B | kmark . d g t
Final Project Day 2 Impress A&J OCU men S

Cther Features

* e-book
reading

Insert new bookmark

lOpenOﬁlce org Training Notes & Exel_vJ i I n Se rt = >
Final Profect - Day 2: Impress BOOkmark

Go to the bookmark created
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* In a Master Document, creating bookmarks are mighty handy.



Table of Contents

3% SO e — S
* Insert -> tream Vera Sa Index/Table |Entries | Styles| Columns | Background |

I n d eX 3 1 Type and title
priocariacan=) Title [Table of Contents
and Table of
. IV Protected against manual charges
OpenOffice.o
a es - > Introductic  Create index/table
Exercisg for Entire document ~| Evaluate upto level 1o =
Exercise ]—i}
naexes Exercisa  Greate from
Exercise = Outline
Exercisg a —J
a n Exercise ™ Additional Styles
Exerciseg
T Writer....... ¥ Index marks
a e S Exarcise
Exercise
Exercise
Exarcise
Exercise
Exercise
. I~ Preview
i oK ‘ Cancel ‘ Help ‘ Reset I B
Final ProjeCh = LAy T7 VWITTE i ceursssreeeessionsesianseereensinsassiamsensasaseneessre U Iq
caln in =
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This feature works well, as long as Styles are used throughout the
document.

It should be noted that exporting to Microsoft Word documents
might make the formatting run on occasion.

The Evaluate up to level tells OO0 what level styles should be
evaluated till.

The Styles tab contains the Levels that are recognized - this can be
changed very easily, by moving over from the Paragraph Styles
section to the Levels section, when it comes to the Assignment.
Enabling a Preview doesn't show the preview relevant to the current
document - its just a general preview.



Bibliographies

* Tools -> Bibliography Database

- Insert -> Record (create a new entry)

- Enter to the next blank record and entry is saved
* Insert -> Indexes and Tables -> Bibliographic

y -
nsert

& From bibiloprphy database == 1
© Erom document content CIOSS
Author Help
Colin Charles
Title g
The OpenOffice.org Training Notes Edit
Short pame
byt=01 |
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Read more about the Bibliographic Project at
http://bibliographic.openoffice.org/



Mail Merge

* For newsletters, mailing address, etc...

- Set up the data

- Create the document to print and bring the
data into it

- Print, then possibly mail it
* File -> AutoPilot -> Letter
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* Keep in mind, there needs to be a “database” for the mail merge to
work - you are welcome to extend upon the Bibliography database
(which is already pre-installed with O00), and get more addresses.
Creation of databases happens much later into this training course.

* To create Envelope labels, Insert -> Envelope is the way. Portrait is
the default setting (and you probably don't want to change it), and
your printer itself must be set to print envelopes.

* File -> New -> Business Cards — design your own (simple) business
cards from within OOo.

* File -> New -> Labels - great for label printing (has many of the
default label brands already available).

Exercise: Practice mail merging

* If you've done mail merges before, the method is similar. Just use the
bibliography database, and pull some entries out. Integrate this with
the template you made earlier, for example.



Revision Control

* Save “snapshots” during creation
* File -> Version

= =
New versions
Close
Click to | Save New Version | I Always save a version on closing Q
save a Existing versions Q
new version Date and time s Date and time : 02/22/2004, 17:30:58 Show...
Saved by Colin Charles —

Insert comments with regards Compare

to why this version was saved,

what the changes were, and so Help

on.

oK ‘ Cancel ‘ Help ‘
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To start saving versions, the base case of the file has to be saved
first. The File -> Version option will be disabled if the document itself
has not been saved.

Opening up read-only versions of snapshots is one of the features
here.

Comparison - Edit -> Changes -> Show will allow you to compare
between two versions.

Tools -> Options -> Text Document -> Changes will allow you to
configure how change management ought to work for your usage
(the defaults are fine).

You can revert to a prior version! Just select the version, click on
Compare, in the Accept or Reject Changes window that pop's up,
select Reject All.



Revision Control and
others

e Edit -> Changes -> Protect Records

- Enter a password

¢ Insert -> Note

Exercise 13: Mail Merging[| «—

Confirm

Password

ST

’Wi
’W Cancel

Help

w8 Double-click

Contents here to
Author CC, 02/22/2004 OK view/edit
Cancel
Text sl | | the note
[This is a note test Help
Help
‘ L —L serol between

Insert Author ior available notes
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When communicating with others, turning on the Protect Changes
feature is real handy. When changes do get made, you can check
them (by doing exactly the same thing you did to protect them).

To view a Note, double click the little yellow box that is next to a Note.
This also allows you to edit a Note.
Remember that Help -> Tips needs to be turned on as well if you
would like the on-mouse-over roll pop-up, i.e. when you move your
mouse over the yellow box, a pop-up appears.



Printing

* Not much different from any other
package

* Interesting options are
- Allowing Notes to be printed
- Pages option for duplex/single printing

* Printer must be fully configured and
spadmin has to recognise it
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* Sometimes it's not called spadmin, rather than oopadmin - this is
dependent on the distribution you've installed OpenOffice.org from.



Thank You!

Colin Charles
byte@aeon.com.my
http://www.bytebot.net/
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